Como o php 7 afetará o WordPress?

A nova versão do php 7 será compatível com versões anteriores ou enfrentaremos problemas de compatibilidade? Isso afetará muito a maneira como codificamos o WordPress? Meu host oferece php 7, devo usá-lo para um site WordPress agora?

Solutions Collecting From Web of "Como o php 7 afetará o WordPress?"

O WordPress prepara-se para o PHP 7 por um tempo e, de acordo com este anúncio , o WordPress deve apoiar o PHP 7 desde 12 de novembro. De acordo com o mesmo anúncio, o WordPress ainda supoortará o PHP 5.2.4 como requisito mínimo, embora seja recomendado pelo menos o PHP 5.6 .

A desvantagem: há propositadamente tantos plugins e temas que não são compatíveis com o PHP 7 que usar o PHP 7 ou não agora não pode ser uma recomendação geral. Se você usa plugins de terceiros, você terá que testar seus sites um por um e pedir à equipe de suporte desses plugins se eles planejam suportar o PHP 7.