Como carregar corretamente este script jquery através do arquivo functions.php?

Estou tentando include e carregar corretamente o script goo.gl/QlJxbk neste site WordPress. Eu segui o doc http://webtechfreaky.github.io/Cloud-Pricing-Slider/docs/index.html para carregar corretamente o script, mas como você pode ver, algo não está funcionando / carregando corretamente. Conforme relatado nos documentos, o script possui 2 colunas, a carga da coluna direita corretamente, a coluna da esquerda não, o ajuste do seletor predefinido para o trabalho, o preço está fora de linha e assim por diante.

O que eu fiz é: carregar a pasta de script dentro do tema da pasta, então enqueue CSS e Script no arquivo functions.php do tema com os seguintes comandos:

Para os estilos // Estilo do controle deslizante de preço

wp_enqueue_style( 'jquery-ui-full-style', get_template_directory_uri() . '/layout/assets/css/jquery-ui.min.css' , array(), '', 'all' ); wp_enqueue_style( 'qs-slider-style', get_template_directory_uri() . '/layout/assets/css/slider.min.css' , array( 'jquery-ui-full-style' ), '', 'all' ); 

e para os scripts // Script de controle deslizante de preço

  wp_enqueue_script( 'jquery-1.11.0', get_template_directory_uri() . '/layout/assets/js/jquery-1.11.0.min.js', array(), '', true ); wp_enqueue_script( 'jquery-ui', get_template_directory_uri() . '/layout/assets/js/jquery-ui.js', array(), '', true ); wp_enqueue_script( 'jquery-ui-min', get_template_directory_uri() . '/layout/assets/js/jquery-ui.min.js', array(), '', true ); wp_enqueue_script( 'qs.slider.init', get_template_directory_uri() . '/layout/assets/js/qs.slider.init.js', array(), '', true ); wp_enqueue_script( 'qs.slider', get_template_directory_uri() . '/layout/assets/js/qs.slider.js', array(), '', true ); 

Provavelmente algo está em conflito, ou a matriz não está corretamente declarada, não consigo realmente entender o que está acontecendo aqui. Qualquer ajuda é apreciada, obrigado.

Solutions Collecting From Web of "Como carregar corretamente este script jquery através do arquivo functions.php?"

Você não precisa include jquery-ui e jquery-ui.min qualquer um deles é suficiente. Também jquery e jquery-ui já estão incluídos no WordPress.

Experimente isso

 wp_enqueue_script( 'jquery'); wp_enqueue_script( 'jquery-ui-core'); wp_enqueue_script( 'qs.slider', get_template_directory_uri() . '/layout/assets/js/qs.slider.js', array('jquery','jquery-ui-core'), '', true ); wp_enqueue_script( 'qs.slider.init', get_template_directory_uri() . '/layout/assets/js/qs.slider.init.js', array('jquery','jquery-ui-core'), '', true ); 

O código acima fará com que jquery e jquery-ui sejam carregados antes de carregar seu controle deslizante.

Carregue os estilos como você já está fazendo.

Observe que apenas o carregamento desses arquivos não fará nada por conta própria, você precisará usar a marcação HTML fornecida pelo autor deste controle deslizante, consulte este código-fonte. E personalize o controle deslizante conforme suas necessidades e, em seguida, adicione a sua página personalizada.