As imagens dão 404 depois de alterar o domínio padrão

Nunca encontrou este problema antes. Então, eu mudei um site para um cliente para outro servidor e, por algum motivo, todas as imagens me dão um 404 quando mudo o domínio padrão no database (siteur e home). CSS, JS e outros arquivos estão corretamente vinculados – parece que há algo afetando a pasta de carregamentos, mas não consigo identificar o que é. Alguma ideia?

Solutions Collecting From Web of "As imagens dão 404 depois de alterar o domínio padrão"

Você deseja executar um script find-and-replace no database para atualizar todos os URLs para refletir o novo domínio. Só porque você muda as configurações do WordPress não significa que o conteúdo armazenado no database foi atualizado com o novo domínio! Eu tive muita sorte com o plugin Velvet Blues Update URLs, mas também pode fazer este tipo de encontrar e replace atualização usando phpMyAdmin ou outras ferramentas de database similares.

Você deve atualizar os URLs no database. Aqui está uma ferramenta que você pode usar https://interconnectit.com/products/search-and-replace-for-wordpress-databases/

Você pode baixá-lo, descompactá-lo e enviá-lo para o servidor, onde você deve replace os URLs e então pode executá-lo.

É muito simples. Você deve inserir URLs de base antigos e novos. Você também pode executar uma corrida seca, verificar as mudanças e depois ir para a execução ao vivo.

Claro que você pode fazer como por algumas outras pessoas lhe deram para percorrer o database e corrigi-lo. Mas também pode quebrar se não for feito corretamente.

Antes de entrar no modo Banco de Dados, sugiro uma coisa que aconteceu comigo.

Primeiro, certifique-se de que você vá nas configurações do WordPress e certifique-se de que os URLs sejam bons … INCLUSO se eles são bons GUARDE CONFIGURAÇÕES uma vez mais para garantir que as configurações sejam refletidas em todos os lugares.

Ao usar plugins para mover sites em torno dessas configurações não parece refletir em todos os lugares, mesmo que essa informação aqui seja boa.

Além disso, eu sugeriria que passasse pela maioria de suas Configurações (Por exemplo, Permalinks) e Configurações de Plugins (Por exemplo, Polylang eu tive um problema com isso, pois há informações de PATH nele) e veja se há alguma relação com “PATH” se houver é garantir que eles tenham a boa informação e SAVE THEM AGAIN mesmo que tenham a informação adequada.

Algum tempo para certificar-se de que a mudança entre em vigor … Coloco uma informação errada e adicione as informações apropriadas novamente e salve novamente … Por que eu faço isso, eu conheço alguns programadores que não “salvam” as informações se foi o mesmo antes e depois de editar dessa forma, você tem certeza de que as informações são transferidas corretamente.