ACF – Campos personalizados desapareceram

Usando o plugin Advanced Custom Fields, meus campos personalizados desapareceram de ‘Novas postagens’ no back-end ‘Admin’.

Os campos também não estão listados em opções de canvas.

Solutions Collecting From Web of "ACF – Campos personalizados desapareceram"

muda para o WP-admin ou possivelmente atualizando o administrador do WP. Você estava usando os campos personalizados padrão ou um plugin de terceiros? Também pode ser algo de um novo tema que você instalou? Precisa de um pouco mais de detalhes sobre o que mudou entre a última vez que funcionou corretamente e agora para responder de forma mais concisa.

Eu fiz um cliente perguntar isso recentemente depois de atualizar o WP e acabou por ser muito simples verificar se o ‘Modelo de campo personalizado’ está marcado no menu suspenso ‘Opções de canvas’ no canto superior direito do wp-admin.

Estou enfrentando esse problema com o plugin ACF. Nas minhas postagens personalizadas, a opção para mostrar / ocultar campos ACF (nas opções de canvas) não está mais disponível e os campos ACF também não estão visíveis.

Depois de fazer a resolução de problemas usual:

  • Desligue todos os plug-ins
  • ativar ACF
  • tente fazer novos campos ACF caso os antigos sejam de alguma forma corrompidos
  • tente reinstalar o ACF a partir do zero
  • ativar a debugging do ACF e verificar o registro de erros

e não descobrindo nada, coloco meu site de volta. Então eu pensei: “Eu me pergunto se alguma coisa ACF apareceu na página fonte HTML?”. Com certeza, houve uma checkbox de seleção ACF do show / hide em Opções de canvas. Mas estava escondido . Isto é o que o Firebug mostra:

 

que tem esse estilo:

 #screen-meta label[for="acf_input-hide"] { display: none; } 

Ainda não encontrei uma solução permanente. Mas, no FireFox, usando o Firebug, posso desativar o display:none e definir a visibilidade ACF como eu, enquanto crio / edito uma postagem personalizada. Não é otimizado, pois a configuração não se mantém. Mas é um trabalho decente.

Tendo o mesmo problema que o dnagirl acima com o ACF, mas encontrei uma solução temporária para esse problema (melhor que usar o Firebug):

No seu servidor web, abra os plugins> avançados-campos personalizados> css> input.css. Ou no WP, vá para Plugins e depois edite o complemento Advanced Custom Fields, clique em “advanced-custom-fields / css / input.css” na coluna da direita. Adicione o seguinte CSS (não importa onde):

 .acf_postbox { display: block !important; } 

Alguém encontrou uma solução ou causa mais permanente? Essa correção que postei provavelmente irá parar de funcionar sempre que o plugin for atualizado e teria que ser feito de novo.